Hi, On 06/01/2021 16:22, Michael Tremer wrote: > Hi, > >> On 5 Jan 2021, at 14:20, Adolf Belka wrote: >> >> - Update sshfs from 2.2 to 3.7.1 >> - Changelog is available at https://github.com/libfuse/sshfs/releases >> - Build had to be changed from autotools to meson/ninja >> - Change in rootfiles >> >> Signed-off-by: Adolf Belka >> --- >> config/rootfiles/common/sshfs | 2 ++ >> lfs/sshfs | 14 ++++++-------- >> 2 files changed, 8 insertions(+), 8 deletions(-) >> >> diff --git a/config/rootfiles/common/sshfs b/config/rootfiles/common/sshfs >> index 2cafa3e24..579b938f5 100644 >> --- a/config/rootfiles/common/sshfs >> +++ b/config/rootfiles/common/sshfs >> @@ -1,2 +1,4 @@ >> usr/bin/sshfs >> +#usr/sbin/mount.fuse.sshfs >> +#usr/sbin/mount.sshfs >> #usr/share/man/man1/sshfs.1 >> diff --git a/lfs/sshfs b/lfs/sshfs >> index 23fbd18ca..1e7706194 100644 >> --- a/lfs/sshfs >> +++ b/lfs/sshfs >> @@ -24,10 +24,10 @@ >> >> include Config >> >> -VER = 2.2 >> +VER = 3.7.1 >> >> -THISAPP = sshfs-fuse-$(VER) >> -DL_FILE = $(THISAPP).tar.gz >> +THISAPP = sshfs-$(VER) >> +DL_FILE = $(THISAPP).tar.xz >> DL_FROM = $(URL_IPFIRE) >> DIR_APP = $(DIR_SRC)/$(THISAPP) >> TARGET = $(DIR_INFO)/$(THISAPP) >> @@ -40,7 +40,7 @@ objects = $(DL_FILE) >> >> $(DL_FILE) = $(DL_FROM)/$(DL_FILE) >> >> -$(DL_FILE)_MD5 = 26e9206eb5169e87e6f95f54bc005a4f >> +$(DL_FILE)_MD5 = 22ac23d05ca7c56fb568627f086374d0 >> >> install : $(TARGET) >> >> @@ -72,9 +72,7 @@ $(subst %,%_MD5,$(objects)) : >> >> $(TARGET) : $(patsubst %,$(DIR_DL)/%,$(objects)) >> @$(PREBUILD) >> - @rm -rf $(DIR_APP) && cd $(DIR_SRC) && tar zxf $(DIR_DL)/$(DL_FILE) >> - cd $(DIR_APP) && ./configure --prefix=/usr >> - cd $(DIR_APP) && make $(MAKETUNING) >> - cd $(DIR_APP) && make install >> + @rm -rf $(DIR_APP) && cd $(DIR_SRC) && tar axf $(DIR_DL)/$(DL_FILE) >> + cd $(DIR_APP) && meson --prefix=/usr builddir && cd builddir && ninja && ninja install > > You could have written those into separate lines instead of all in one. That would have been slightly easier to read and change. That makes sense to do it like that. Should I redo this patch as a v2. When I split the parts onto different lines do I need to prefix each line with the cd $(DIR_APP) like the old .configure, make, make install sequence had. > >> @rm -rf $(DIR_APP) >> @$(POSTBUILD) >> -- >> 2.30.0 >> >