public inbox for development@lists.ipfire.org
 help / color / mirror / Atom feed
From: Robin Roevens <robin.roevens@disroot.org>
To: development@lists.ipfire.org
Subject: Re: [PATCH 4/9] pakfire: Replace coreupdate_available duplicate code
Date: Wed, 23 Mar 2022 22:50:43 +0100	[thread overview]
Message-ID: <0797afa9274536985f5adbe1c213dfc28993ec0a.camel@sicho.home> (raw)
In-Reply-To: <ffb31ceae1c29f32035fa42aa6a611c60c842af4.camel@sicho.home>

[-- Attachment #1: Type: text/plain, Size: 2539 bytes --]

Hi

Robin Roevens schreef op di 22-03-2022 om 13:42 [+0100]:
> Hi Michael
> 
> Michael Tremer schreef op ma 21-03-2022 om 16:21 [+0000]:
> > This is a lot nicer without eval().
> > 
> > > On 9 Mar 2022, at 22:56, Robin Roevens
> > > <robin.roevens(a)disroot.org>
> > > wrote:
> > > 
> > > Replace coreupdate_available code duplicating coredbinfo
> > > workings with call to actual coredbinfo function.
> > > 
> > > Signed-off-by: Robin Roevens <robin.roevens(a)disroot.org>
> > > ---
> > > src/pakfire/lib/functions.pl | 7 ++++---
> > > 1 file changed, 4 insertions(+), 3 deletions(-)
> > > 
> > > diff --git a/src/pakfire/lib/functions.pl
> > > b/src/pakfire/lib/functions.pl
> > > index 0caa4787e..1e2729485 100644
> > > --- a/src/pakfire/lib/functions.pl
> > > +++ b/src/pakfire/lib/functions.pl
> > > @@ -884,9 +884,10 @@ sub updates_available {
> > > }
> > > 
> > > sub coreupdate_available {
> > > -       eval(`grep "core_" $Conf::dbdir/lists/core-list.db`);
> > > -       if ("$core_release" > "$Conf::core_mine") {
> > > -               return "yes ($core_release)";
> > > +       my %coredb = &Pakfire::coredbinfo();
> > > +
> > > +       if ("$coredb{'AvailableRelease'}" > "$coredb{'Release'}")
> > > {
> > > +               return "yes ($coredb{'AvailableRelease'})";
> > >         }
> > >         else {
> > >                 return "no";
> > 
> > Is returning a string what we want here?
> Valid question.. I will look into it. In the light of moving UI out
> of
> the library functions that would certainly be the right thing to do
> (not returning strings here).

I looked into it and found out that the only place where this function
is actually used is in Pakfire::status which I rewrite a few patches
later and this function becomes obsolete.
So this patch is actually pointless :-).. I will remove it and remove
the function coreupdate_available.
This information is available from either function coredbinfo (wether
key 'AvailableRelease' exists) of from the new status function (returns
hash with a key 'CoreUpdateAvailable' = yes/no)

Robin
> 
> > 
> > > -- 
> > > 2.34.1
> > > 
> > > 
> > > -- 
> > > Dit bericht is gescanned op virussen en andere gevaarlijke
> > > inhoud door MailScanner en lijkt schoon te zijn.
> > > 
> > 
> > 
> 

-- 
Dit bericht is gescanned op virussen en andere gevaarlijke
inhoud door MailScanner en lijkt schoon te zijn.


  reply	other threads:[~2022-03-23 21:50 UTC|newest]

Thread overview: 35+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2022-03-09 22:56 [PATCH 0/9] pakfire: remove dup. code + seperate ui/logic Robin Roevens
2022-03-09 22:56 ` [PATCH 1/9] pakfire: Refactor dblist seperating UI and logic Robin Roevens
2022-03-21 16:18   ` Michael Tremer
2022-03-22 12:39     ` Robin Roevens
2022-03-23 19:18       ` Robin Roevens
2022-03-23 20:49         ` Michael Tremer
2022-03-09 22:56 ` [PATCH 2/9] pakfire: Replace duplicate code with dblist functioncall Robin Roevens
2022-03-21 16:20   ` Michael Tremer
2022-03-09 22:56 ` [PATCH 3/9] pakfire: Replace dbgetlist duplicate code Robin Roevens
2022-03-21 16:21   ` Michael Tremer
2022-03-09 22:56 ` [PATCH 4/9] pakfire: Replace coreupdate_available " Robin Roevens
2022-03-21 16:21   ` Michael Tremer
2022-03-22 12:42     ` Robin Roevens
2022-03-23 21:50       ` Robin Roevens [this message]
2022-03-09 22:56 ` [PATCH 5/9] pakfire: Optimize upgradecore function Robin Roevens
2022-03-21 16:24   ` Michael Tremer
2022-03-22 12:58     ` Robin Roevens
2022-03-22 15:16       ` Michael Tremer
2022-03-09 22:56 ` [PATCH 6/9] pakfire: Add list upgrade functionality Robin Roevens
2022-03-21 16:33   ` Michael Tremer
2022-03-22 12:59     ` Robin Roevens
2022-03-09 22:56 ` [PATCH 7/9] pakfire: Refactor status function separating UI and logic Robin Roevens
2022-03-21 16:28   ` Michael Tremer
2022-03-23 19:56     ` Robin Roevens
2022-03-23 20:48       ` Michael Tremer
2022-03-09 22:56 ` [PATCH 8/9] pakfire: Add getmetadata function Robin Roevens
2022-03-21 16:32   ` Michael Tremer
2022-03-22 13:28     ` Robin Roevens
2022-03-23 11:28       ` Michael Tremer
2022-03-09 22:56 ` [PATCH 9/9] pakfire: Redesign update output and workflow Robin Roevens
2022-03-21 16:36   ` Michael Tremer
2022-03-22 18:32     ` Robin Roevens
2022-03-23 10:30       ` Michael Tremer
2022-03-09 23:46 ` [PATCH 0/9] pakfire: remove dup. code + seperate ui/logic Tom Rymes
2022-03-09 23:56   ` Paul Simmons

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=0797afa9274536985f5adbe1c213dfc28993ec0a.camel@sicho.home \
    --to=robin.roevens@disroot.org \
    --cc=development@lists.ipfire.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox