From: Michael Tremer <michael.tremer@ipfire.org>
To: development@lists.ipfire.org
Subject: Re: [PATCH 5/9] pakfire: Optimize upgradecore function
Date: Mon, 21 Mar 2022 16:24:58 +0000 [thread overview]
Message-ID: <B1C91D59-9483-4D66-BC09-E062FBBBE855@ipfire.org> (raw)
In-Reply-To: <20220309225655.4472-6-robin.roevens@disroot.org>
[-- Attachment #1: Type: text/plain, Size: 4062 bytes --]
Hello,
> On 9 Mar 2022, at 22:56, Robin Roevens <robin.roevens(a)disroot.org> wrote:
>
> upgradecore function should just upgrade the core:
> Moved check if upgrade is necessary to pakfire upgrade code, removing
> code from upgradecore function duplicating codedbinfo workings.
> Also adding more vebosity to pakfire upgrade.
>
> Signed-off-by: Robin Roevens <robin.roevens(a)disroot.org>
> ---
> src/pakfire/lib/functions.pl | 47 +++++++++++++++---------------------
> src/pakfire/pakfire | 16 +++++++++++-
> 2 files changed, 35 insertions(+), 28 deletions(-)
>
> diff --git a/src/pakfire/lib/functions.pl b/src/pakfire/lib/functions.pl
> index 1e2729485..6287367f5 100644
> --- a/src/pakfire/lib/functions.pl
> +++ b/src/pakfire/lib/functions.pl
> @@ -735,35 +735,28 @@ sub setuppak {
> }
>
> sub upgradecore {
> - getcoredb("noforce");
> - eval(`grep "core_" $Conf::dbdir/lists/core-list.db`);
> - if ("$core_release" > "$Conf::core_mine") {
> - # Safety check for lazy testers:
> - # Before we upgrade to the latest release, we re-install the previous release
> - # to make sure that the tester has always been on the latest version.
> - my $tree = &get_tree();
> - $Conf::core_mine-- if ($tree eq "testing" || $tree eq "unstable");
> -
> - message("CORE UPGR: Upgrading from release $Conf::core_mine to $core_release");
> -
> - my @seq = `seq $Conf::core_mine $core_release`;
> - shift @seq;
> - my $release;
> - foreach $release (@seq) {
> - chomp($release);
> - getpak("core-upgrade-$release");
> - }
> -
> - foreach $release (@seq) {
> - chomp($release);
> - upgradepak("core-upgrade-$release");
> - }
> -
> - system("echo $core_release > $Conf::coredir/mine");
> + # Safety check for lazy testers:
> + # Before we upgrade to the latest release, we re-install the previous release
> + # to make sure that the tester has always been on the latest version.
> + my $tree = &get_tree();
> + $Conf::core_mine-- if ($tree eq "testing" || $tree eq "unstable");
>
> - } else {
> - message("CORE ERROR: No new upgrades available. You are on release $Conf::core_mine.");
> + message("CORE UPGR: Upgrading from release $Conf::core_mine to $core_release");
> +
> + my @seq = `seq $Conf::core_mine $core_release`;
Can we remove this shell command call? This should be easily replaced with native Perl.
> + shift @seq;
> + my $release;
> + foreach $release (@seq) {
> + chomp($release);
> + getpak("core-upgrade-$release");
> }
> +
> + foreach $release (@seq) {
> + chomp($release);
> + upgradepak("core-upgrade-$release");
> + }
> +
> + system("echo $core_release > $Conf::coredir/mine");
> }
>
> sub isinstalled {
> diff --git a/src/pakfire/pakfire b/src/pakfire/pakfire
> index f23110cf5..2fb9adce7 100644
> --- a/src/pakfire/pakfire
> +++ b/src/pakfire/pakfire
> @@ -266,7 +266,21 @@
> $use_color = "$Pakfire::color{'lightpurple'}";
> }
>
> - &Pakfire::upgradecore();
> + &Pakfire::message("CORE INFO: Checking for Core updates...");
> +
> + ### Make sure that the core db is not outdated.
> + &Pakfire::getcoredb("noforce");
> + my %coredb = &Pakfire::coredbinfo();
> +
> + if (defined $coredb{'AvailableRelease'}) {
> + &Pakfire::upgradecore();
> + } else {
> + &Pakfire::message("CORE WARN: No new Core upgrades available. You are on release ".$coredb{'Release'});
Here, the Core Update is being called Core Upgrade. That might be coming from somewhere else. In the end we should probably reword lots of the error messages to make them consistent and easy to understand.
> + }
> +
> + &Pakfire::message("PAKFIRE INFO: Checking for package updates...");
> + ### Make sure that the package list is not outdated.
> + &Pakfire::dbgetlist("noforce");
>
> my @deps = ();
> if (my %upgradepaks = &Pakfire::dblist("upgrade")) {
> --
> 2.34.1
>
>
> --
> Dit bericht is gescanned op virussen en andere gevaarlijke
> inhoud door MailScanner en lijkt schoon te zijn.
>
next prev parent reply other threads:[~2022-03-21 16:24 UTC|newest]
Thread overview: 35+ messages / expand[flat|nested] mbox.gz Atom feed top
2022-03-09 22:56 [PATCH 0/9] pakfire: remove dup. code + seperate ui/logic Robin Roevens
2022-03-09 22:56 ` [PATCH 1/9] pakfire: Refactor dblist seperating UI and logic Robin Roevens
2022-03-21 16:18 ` Michael Tremer
2022-03-22 12:39 ` Robin Roevens
2022-03-23 19:18 ` Robin Roevens
2022-03-23 20:49 ` Michael Tremer
2022-03-09 22:56 ` [PATCH 2/9] pakfire: Replace duplicate code with dblist functioncall Robin Roevens
2022-03-21 16:20 ` Michael Tremer
2022-03-09 22:56 ` [PATCH 3/9] pakfire: Replace dbgetlist duplicate code Robin Roevens
2022-03-21 16:21 ` Michael Tremer
2022-03-09 22:56 ` [PATCH 4/9] pakfire: Replace coreupdate_available " Robin Roevens
2022-03-21 16:21 ` Michael Tremer
2022-03-22 12:42 ` Robin Roevens
2022-03-23 21:50 ` Robin Roevens
2022-03-09 22:56 ` [PATCH 5/9] pakfire: Optimize upgradecore function Robin Roevens
2022-03-21 16:24 ` Michael Tremer [this message]
2022-03-22 12:58 ` Robin Roevens
2022-03-22 15:16 ` Michael Tremer
2022-03-09 22:56 ` [PATCH 6/9] pakfire: Add list upgrade functionality Robin Roevens
2022-03-21 16:33 ` Michael Tremer
2022-03-22 12:59 ` Robin Roevens
2022-03-09 22:56 ` [PATCH 7/9] pakfire: Refactor status function separating UI and logic Robin Roevens
2022-03-21 16:28 ` Michael Tremer
2022-03-23 19:56 ` Robin Roevens
2022-03-23 20:48 ` Michael Tremer
2022-03-09 22:56 ` [PATCH 8/9] pakfire: Add getmetadata function Robin Roevens
2022-03-21 16:32 ` Michael Tremer
2022-03-22 13:28 ` Robin Roevens
2022-03-23 11:28 ` Michael Tremer
2022-03-09 22:56 ` [PATCH 9/9] pakfire: Redesign update output and workflow Robin Roevens
2022-03-21 16:36 ` Michael Tremer
2022-03-22 18:32 ` Robin Roevens
2022-03-23 10:30 ` Michael Tremer
2022-03-09 23:46 ` [PATCH 0/9] pakfire: remove dup. code + seperate ui/logic Tom Rymes
2022-03-09 23:56 ` Paul Simmons
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=B1C91D59-9483-4D66-BC09-E062FBBBE855@ipfire.org \
--to=michael.tremer@ipfire.org \
--cc=development@lists.ipfire.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox