From mboxrd@z Thu Jan 1 00:00:00 1970 From: Michael Tremer To: development@lists.ipfire.org Subject: Re: [PATCH 4/9] pakfire: Replace coreupdate_available duplicate code Date: Mon, 21 Mar 2022 16:21:48 +0000 Message-ID: In-Reply-To: <20220309225655.4472-5-robin.roevens@disroot.org> MIME-Version: 1.0 Content-Type: multipart/mixed; boundary="===============2873321494133336324==" List-Id: --===============2873321494133336324== Content-Type: text/plain; charset="utf-8" Content-Transfer-Encoding: 7bit This is a lot nicer without eval(). > On 9 Mar 2022, at 22:56, Robin Roevens wrote: > > Replace coreupdate_available code duplicating coredbinfo > workings with call to actual coredbinfo function. > > Signed-off-by: Robin Roevens > --- > src/pakfire/lib/functions.pl | 7 ++++--- > 1 file changed, 4 insertions(+), 3 deletions(-) > > diff --git a/src/pakfire/lib/functions.pl b/src/pakfire/lib/functions.pl > index 0caa4787e..1e2729485 100644 > --- a/src/pakfire/lib/functions.pl > +++ b/src/pakfire/lib/functions.pl > @@ -884,9 +884,10 @@ sub updates_available { > } > > sub coreupdate_available { > - eval(`grep "core_" $Conf::dbdir/lists/core-list.db`); > - if ("$core_release" > "$Conf::core_mine") { > - return "yes ($core_release)"; > + my %coredb = &Pakfire::coredbinfo(); > + > + if ("$coredb{'AvailableRelease'}" > "$coredb{'Release'}") { > + return "yes ($coredb{'AvailableRelease'})"; > } > else { > return "no"; Is returning a string what we want here? > -- > 2.34.1 > > > -- > Dit bericht is gescanned op virussen en andere gevaarlijke > inhoud door MailScanner en lijkt schoon te zijn. > --===============2873321494133336324==--