public inbox for network@lists.ipfire.org
 help / color / mirror / Atom feed
From: Michael Tremer <michael.tremer@ipfire.org>
To: network@lists.ipfire.org
Subject: Re: [PATCH 1/8] zone: add config hid functions
Date: Tue, 25 Jul 2017 23:22:31 +0100	[thread overview]
Message-ID: <1501021351.20312.31.camel@ipfire.org> (raw)
In-Reply-To: <1500998833-10543-2-git-send-email-jonatan.schlag@ipfire.org>

[-- Attachment #1: Type: text/plain, Size: 4045 bytes --]

Hi,

On Tue, 2017-07-25 at 18:07 +0200, Jonatan Schlag wrote:
> The following patch adds the basic functions which are we need to work with
> hids.
> 
> Fixes: #11406 (partially)
> 
> Signed-off-by: Jonatan Schlag <jonatan.schlag(a)ipfire.org>
> ---
>  src/functions/functions.zone | 86
> ++++++++++++++++++++++++++++++++++++++++++++
>  1 file changed, 86 insertions(+)
> 
> diff --git a/src/functions/functions.zone b/src/functions/functions.zone
> index bba1705..28a22fe 100644
> --- a/src/functions/functions.zone
> +++ b/src/functions/functions.zone
> @@ -656,6 +656,75 @@ zone_config_list_ids() {
>  	echo ${ids}
>  }
>  
> +# List all hids of a zone
> +zone_config_list_hids() {
> +	assert [ $# -eq 1 ]
> +	local zone=${1}
> +
> +	local config
> +	local hids
> +
> +	for config in $(zone_configs_list ${zone}); do
> +		# Get hook from config
> +		hook="$(zone_config_get_hook "${zone}" "${config}")"
> +		# Append hids to the list
> +		list_append hids "$(zone_config_get_hid "${zone}"
> "${config}")"
> +	done
> +
> +	echo ${hids}
> +}

In this function, you are using a hook variable that is never initalised nor
used. So I would say that can just be removed.

And unless you insist that the function returns its result in one line, you
could just let "zone_config_get_hid" write to stdout and remove the hids
variable and list_append entirely. That will make this function way faster since
it doesn't need to fork as many sub-shells.

> +
> +# get the hid from a given config
> +zone_config_get_hid() {
> +	assert [ $# -eq 2 ]
> +	local zone=${1}
> +	local config=${2}
> +
> +	local hook
> +
> +	hook="$(zone_config_get_hook "${zone}" "${config}")"
> +	echo "$(hook_exec "config" "${hook}" "hid" "${zone}" "${config}")"
> +}

Same here:

  echo "$(some function)"

could just be:

  some function

Same result. But doesn't call echo or the sub-shell to call the function.

> +
> +# Checks if a hid is valid for a given zone
> +zone_config_hid_is_valid() {
> +	assert [ $# -eq 2]
> +	local zone=${1}
> +	local hid=${2}
> +
> +	local _hid
> +	for _hid in $(zone_config_list_hids "${zone}"); do
> +		if [[ ${_hid} == ${hid} ]]; then
> +			return ${EXIT_TRUE}
> +		fi
> +	done
> +
> +	return ${EXIT_FALSE}
> +
> +}

Empty line before the closing bracket of the function.

And the check for equality in POSIX shell is just "=" and not "==".

> +
> +# This function converts a hid to a id
> +zone_config_convert_hid_to_id() {
> +	assert [ $# -eq 2 ]
> +	local zone=${1}
> +	local hid=${2}
> +
> +	local hook
> +	local config
> +	local id
> +
> +	for config in $(zone_configs_list ${zone}); do
> +		# Get hook from config
> +		hook="$(zone_config_get_hook "${zone}" "${config}")"
> +		if [[ "$(hook_exec "config" "${hook}" "hid" "${zone}"
> "${config}")" == "${hid}" ]]; then
> +			id=$(config_get_id_from_config "${config}")
> +			break
> +		fi
> +	done
> +
> +	echo ${id}
> +}

Same as above. You could just let "config_get_id_from_config" print the ID and
then break or return. The ID variable is not needed.

> +
>  zone_show() {
>  	local zone=${1}
>  
> @@ -1114,6 +1183,23 @@ zone_config_id_is_valid() {
>  	[ -f ${zone_path}/configs/*.${id} ];
>  }
>  
> +# This function checks if a given hid is valid for a zone
> +# Return True when yes and false when no
> +zone_config_hid_is_valid() {
> +	assert [ $# -eq 2 ]
> +	local zone=${1}
> +	local hid=${2}
> +
> +	local _hid
> +	for _hid in $(zone_config_list_hids ${zone}); do
> +		if [[ ${_hid} == ${hid} ]]; then
> +			return ${EXIT_TRUE}
> +		fi
> +	done
> +
> +	return ${EXIT_FALSE}
> +}

This function is a duplicate.

I also think it should be called "zone_config_hid_exists" or
so since we technically don't know what a valid HID looks like. Every hook can
have something different here.

> +
>  zone_config_get_hook_from_id() {
>  	# Returns the hook for a given id
>  	assert [ $# -eq 2 ]

Best,
-Michael

[-- Attachment #2: signature.asc --]
[-- Type: application/pgp-signature, Size: 819 bytes --]

  reply	other threads:[~2017-07-25 22:22 UTC|newest]

Thread overview: 14+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2017-07-25 16:07 Add hids Jonatan Schlag
2017-07-25 16:07 ` [PATCH 1/8] zone: add config hid functions Jonatan Schlag
2017-07-25 22:22   ` Michael Tremer [this message]
2017-07-25 16:07 ` [PATCH 2/8] zone: accept also hids in zone_config() Jonatan Schlag
2017-07-25 22:27   ` Michael Tremer
2017-07-25 16:07 ` [PATCH 3/8] zone: config list print also hids Jonatan Schlag
2017-07-25 22:28   ` Michael Tremer
2017-07-25 16:07 ` [PATCH 4/8] hook: also hook_hid is a valid command Jonatan Schlag
2017-07-25 16:07 ` [PATCH 5/8] header-config: add generic hhok_hid function Jonatan Schlag
2017-07-25 22:29   ` Michael Tremer
2017-07-25 16:07 ` [PATCH 6/8] raw: add command list-zone-config-hids Jonatan Schlag
2017-07-25 16:07 ` [PATCH 7/8] raw: add command zone-config-hid-is-valid Jonatan Schlag
2017-07-25 16:07 ` [PATCH 8/8] autocompletion: use hids instead of ids Jonatan Schlag
2017-07-25 22:30   ` Michael Tremer

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=1501021351.20312.31.camel@ipfire.org \
    --to=michael.tremer@ipfire.org \
    --cc=network@lists.ipfire.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox