From mboxrd@z Thu Jan 1 00:00:00 1970 From: Jonatan Schlag To: network@lists.ipfire.org Subject: [PATCH 3/5] device: add new function device_tunnel_get_type() Date: Sun, 04 Mar 2018 18:24:57 +0000 Message-ID: <1520187899-5759-3-git-send-email-jonatan.schlag@ipfire.org> In-Reply-To: <1520187899-5759-1-git-send-email-jonatan.schlag@ipfire.org> MIME-Version: 1.0 Content-Type: multipart/mixed; boundary="===============2045954324088670704==" List-Id: --===============2045954324088670704== Content-Type: text/plain; charset="utf-8" Content-Transfer-Encoding: 7bit If we already know that the device must be a ip-tunnel device we can save time when we check just for the types a ip-tunnel device can have. To avoid code duplication we call this function from device_get_type() Signed-off-by: Jonatan Schlag --- src/functions/functions.device | 18 ++++++++++++++++++ 1 file changed, 18 insertions(+) diff --git a/src/functions/functions.device b/src/functions/functions.device index a04111e..0cd6e4e 100644 --- a/src/functions/functions.device +++ b/src/functions/functions.device @@ -396,9 +396,27 @@ device_get_type() { elif device_is_phy ${device}; then echo "phy" + else + echo "$(device_tunnel_get_type "${device}")" + fi +} + +# This function just checks the types a ip-tunnel device usually have +# so when we know that the device is an ip-tunnel device we save time +device_tunnel_get_type() { + local device=${1} + + # If the device does not exist (happens on udev remove events), + # we do not bother to run all checks. + if ! device_exists "${device}"; then + echo "unknown" + elif device_is_vti ${device}; then echo "vti" + elif device_is_vti6 ${device}; then + echo "vti6" + else echo "unknown" fi -- 2.6.3 --===============2045954324088670704==--