Problems with Core 70 and OpenVPN N2N

Erik K. ummeegge at ipfire.org
Thu Jul 11 20:33:49 CEST 2013


Hi all,
have tried today Core 70 and OpenVPN N2N and i have had problems to establish the connection. 

The infrastructure:

IPFire (remote) <--> Router <--> [ Internet ] <--> (local) Router <-->  (local) IPFire

So both sides with double NAT. The log messages gives me the following back

Jul 11 18:17:35 ipfire Testn2n[13565]: UDPv4 link remote: 192.168.20.2:5329
Jul 11 18:19:09 ipfire Testn2n[13808]: TLS Error: client->client or server->server connection attempted from 192.168.20.2:5329
Jul 11 18:18:01 ipfire Testn2n[13565]: event_wait : Interrupted system call (code=4)
have never seen this message (in the middle) before...

So i looked to the configuration file on the TLS-client where the "Remote Host/IP" was stated with the 192.168.20.2 (red0 IP), i changed it then to the remote IP (in versions before Core 70 this was not necessary) and the following log output was stated.

Jul 11 20:22:49 ipfire Testn2n[6875]: Expected Remote Options hash (VER=V4): '9e986809'
Jul 11 20:22:49 ipfire-bbach Testn2n[[6875]: UDPv4 link remote: 172.11.xx.xx:5329
Jul 11 20:23:50 ipfire Testn2n[[6875]: [UNDEF] Inactivity timeout (--ping-restart), restarting


Looks like a closed firewall. Portforwarding from both upstream routers to IPFire was made, outgoing FW was in mode 0 .

May some one have an idea what´s causing this problem ?


Greetings 


Erik




More information about the Development mailing list