compiling an actual version of python

Michael Tremer michael.tremer at ipfire.org
Sat Feb 7 13:23:27 CET 2015


Hi,

I don't know what you downloaded, but it does not seem to be the right
thing.

You will need to check out the Git repository. How to do that is shown
over here:

  http://wiki.ipfire.org/en/development/git

Ignore the IPFire 3 stuff. After that, you will need to do what is
described in the build howto:

  http://wiki.ipfire.org/en/development/build

Apart from that, there is also this:

  http://wiki.ipfire.org/en/development/addon

Good luck,
-Michael

On Sat, 2015-02-07 at 12:37 +0100, robert rottermann wrote:
> thanks for the info
> On 06.02.2015 00:37, Michael Tremer wrote:
> > Hello,
> >
> > indeed the Python version is not the most recent one. And that answers
> > your question as well: No one is currently working on an update of this,
> > but we would be happy if you would look into that and send us the
> > patches.
> >
> > Generally I don't see any problems you might expect. Please stick to the
> > latest version of Python 2.7 as most (if not all) python code that we
> > use in IPFire is not compatible with Python 3.x.
> >
> > If there are any questions, feel free to consult us here on this list.
> > Arne already pointed you to where to start from.
> >
> > -Michael
> 
> i started with cloning the  ipfire source.
> now I am struck with downloading the toolchain (or wath ever is needed)
> I do not find:
> 
> make.sh
> 
> anywhere in the dowloaded repo
> 
> robert
> 
> >
> > On Thu, 2015-02-05 at 14:35 +0100, robert rottermann wrote:
> >> Hi Michael,
> >> On 05.02.2015 14:23, Michael Tremer wrote:
> >>> Hello Robert,
> >>>
> >>> IPFire already comes with Python on board.
> >> yes, I know that
> >>> [root at ipfire ~]# python
> >>> Python 2.7.3 (default, Aug 23 2013, 19:24:00)
> >>> [GCC 4.4.7] on linux2
> >>> Type "help", "copyright", "credits" or "license" for more information.
> >>> What are you missing and what do you want to do?
> >> actual is 2.7.9, which has some features not available in 2.7.3
> >>
> >> actually I would like to install some python libraries, and to install
> >> them I need an actual version of the setup tools..
> >> But they do not run under 2.7.3 ..
> >>
> >> robert
> >>
> >>> -Michael
> >>>
> >>> On Thu, 2015-02-05 at 11:03 +0100, robert rottermann wrote:
> >>>> Hi ,
> >>>>
> >>>> I am new to this list and would like to say hi to everybody.
> >>>>
> >>>> As I am an old python hand, I would like to have an actual python
> >>>> running on ipfire.
> >>>> So that will be my first attempt to get my feet wet with developing for
> >>>> ipfire.
> >>>>
> >>>> now my question: is such an project already in the works by somebody of you?
> >>>>
> >>>> thanks
> >>>> robert
> >>>> _______________________________________________
> >>>> Development mailing list
> >>>> Development at lists.ipfire.org
> >>>> http://lists.ipfire.org/mailman/listinfo/development
> 



More information about the Development mailing list