[PATCH] perl-Net-SSLeay: Update to 1.78.

Stefan Schantl stefan.schantl at ipfire.org
Sat Sep 3 10:47:01 CEST 2016


This is an update to the latest stable version.

Add dependencies information to cover perl ABI version and
missing perl dependencies.

Fixes #11175.

Signed-off-by: Stefan Schantl <stefan.schantl at ipfire.org>
Tested-by: Alexander Marx <alexander.marx at ipfire.org>
---
 perl-Net-SSLeay/perl-Net-SSLeay.nm | 8 +++++++-
 1 file changed, 7 insertions(+), 1 deletion(-)

diff --git a/perl-Net-SSLeay/perl-Net-SSLeay.nm b/perl-Net-SSLeay/perl-Net-SSLeay.nm
index 5a6e166..8485c2d 100644
--- a/perl-Net-SSLeay/perl-Net-SSLeay.nm
+++ b/perl-Net-SSLeay/perl-Net-SSLeay.nm
@@ -4,7 +4,7 @@
 ###############################################################################
 
 name       = perl-Net-SSLeay
-version    = 1.69
+version    = 1.78
 release    = 1
 thisapp    = Net-SSLeay-%{version}
 
@@ -40,6 +40,12 @@ end
 
 packages
 	package %{name}
+		requires
+			perl(:MODULE_COMPAT_%{perl_version})
+			perl(MIME::Base64)
+			perl(XSLoader)
+		end
+	end
 
 	package %{name}-debuginfo
 		template DEBUGINFO
-- 
2.5.5



More information about the Development mailing list