IPFire 2.19 - Core Update 114 released

The IPFire Project ipfire-announce at lists.ipfire.org
Fri Oct 6 20:52:52 CEST 2017


http://www.ipfire.org/news/ipfire-2-19-core-update-114-released

This is the official release announcement for IPFire 2.19 – Core Update 114. It
brings some changes under the hood and modernises the base system. On top of
that, minor issues are being fixed and some packages have been updated.


Apache 2.4

The web server that runs the web user interface is Apache, which now has been
updated from 2.2 to the more recent 2.4 version. This mainly patches some
security issues that would potentially have arisen since Apache 2.2 is no longer
maintained.

We have also migrated from the prefork modul to the MPM event system which
reduces the amount of processes running and reduces the memory footprint of the
web user interface and some features like the update accelerator.

Overall, this is change is not significant from the end-user perspective, but
has been necessary to modernise the distribution and make it fit for the future.
Thanks for Wolfgang Apolinarski who has been spearheading this update.
Manual Action Required! For all users that have installed own Virtual Hosts in
Apache, the web user interface won’t restart after the update. Please update the
configuration files to the new configuration file format of Apache 2.4 and then
restart the system. All IPFire add-ons will of course be automatically migrated.

A potential information leak has also been closed where the version of the
IPFire system could be obtained from the local network without logging in to the
web user interface.


Cosmetic Changes

Matthias Fischer and Peter Müller have been working on improving the appearance
of the web user interface with their attention to some details. Among those are
changes to the Wireless Access Point and Proxy pages as well as many
improvements of the German translation which removes typos and rewords many
things for better localisation.


Updated Packages

* gnutls 3.5.15
* hdparm 9.52
* strongswan 5.6.0
* squid 3.5.27
* tcpdump 4.9.2
* unbound 1.6.6


More information about the IPFire-Announce mailing list