The second version of this patch does this in a more Pythonic way.
Signed-off-by: Peter Müller peter.mueller@ipfire.org --- src/python/location-importer.in | 19 +++++++++++++++++-- 1 file changed, 17 insertions(+), 2 deletions(-)
diff --git a/src/python/location-importer.in b/src/python/location-importer.in index da058d3..3ad335f 100644 --- a/src/python/location-importer.in +++ b/src/python/location-importer.in @@ -574,6 +574,21 @@ class CLI(object): # be suitable for libloc consumption... return True
+ def _check_parsed_asn(self, asn): + """ + Assistive function to filter Autonomous System Numbers not being suitable + for adding to our database. Returns False in such cases, and True otherwise. + """ + + validranges = ((1,23455), (23457,64495), (131072, 4199999999)) + + for singlerange in validranges: + if singlerange[0] <= asn and singlerange[1] >= asn: + return True + + log.info("Supplied ASN %s out of publicly routable ASN ranges" % asn) + return False + def _parse_block(self, block, source_key, validcountries = None): # Get first line to find out what type of block this is line = block[0] @@ -829,8 +844,8 @@ class CLI(object): log.debug("Skipping ARIN AS names line not containing an integer for ASN") continue
- if not ((1 <= asn and asn <= 23455) or (23457 <= asn and asn <= 64495) or (131072 <= asn and asn <= 4199999999)): - log.debug("Skipping ARIN AS names line not containing a valid ASN: %s" % asn) + # Filter invalid ASNs... + if not self._check_parsed_asn(asn): continue
# Skip any AS name that appears to be a placeholder for a different RIR or entity...
A while ago, it was discussed whether or not libloc should become an "opinionated database", i. e. including any information on a network's reputation.
In general, this idea was dismissed as libloc is neither intended nor suitable for such tasks, and we do not want to make (political?) decisions like these for various reasons. All we do is to provide a useful location database in a neutral way, and leave it up to our users on how to react on certain results.
However, there is a problematic area. Take AS55303 as an example: We _know_ this is to be a dirty network, tampering with RIR data and hijacking IP space, and strongly recommend against processing any connection originating from or directed to it.
Since it appears to be loaded with proxies used by miscreants for abusive purposes, all we can do at the time of writing is to flag it as "anonymous proxy", but we lack possibility of telling our users something like "this is not a safe area". The very same goes for known bulletproof ISPs, IP hijackers, and so forth.
This patch therefore suggests to populate the "is_drop" flag introduced in libloc 0.9.8 (albeit currently unused in production) with the contents of Spamhaus' DROP lists (https://www.spamhaus.org/drop/), to have at least the baddest of the bad covered. The very same lists are, in fact, included in popular IPS rulesets as well - a decent amount of IPFire users is therefore likely to have them already enabled, but in a very costly way.
It is not planned to go further, partly because there is no other feed publicly available, which would come with the same intention, volatility, and FP rate.
The third version of this patch makes use of an auxiliary function to sanitise ASNs, hence avoiding boilerplate code, and treats any line starting with a semicolon as a comment, which should be sufficient. Further, extracting ASNs from the ASN-DROP feed is done in a more clear way, avoiding code snippets hard to read.
Signed-off-by: Peter Müller peter.mueller@ipfire.org --- src/python/location-importer.in | 110 ++++++++++++++++++++++++++++++++ 1 file changed, 110 insertions(+)
diff --git a/src/python/location-importer.in b/src/python/location-importer.in index 3ad335f..b6a5faa 100644 --- a/src/python/location-importer.in +++ b/src/python/location-importer.in @@ -1074,6 +1074,9 @@ class CLI(object): # network allocation lists in a machine-readable format... self._update_overrides_for_aws()
+ # Update overrides for Spamhaus DROP feeds... + self._update_overrides_for_spamhaus_drop() + for file in ns.files: log.info("Reading %s..." % file)
@@ -1258,6 +1261,113 @@ class CLI(object): )
+ def _update_overrides_for_spamhaus_drop(self): + downloader = location.importer.Downloader() + + ip_urls = [ + "https://www.spamhaus.org/drop/drop.txt", + "https://www.spamhaus.org/drop/edrop.txt", + "https://www.spamhaus.org/drop/dropv6.txt" + ] + + asn_urls = [ + "https://www.spamhaus.org/drop/asndrop.txt" + ] + + for url in ip_urls: + try: + with downloader.request(url, return_blocks=False) as f: + fcontent = f.body.readlines() + except Exception as e: + log.error("Unable to download Spamhaus DROP URL %s: %s" % (url, e)) + return + + # Iterate through every line, filter comments and add remaining networks to + # the override table in case they are valid... + with self.db.transaction(): + for sline in fcontent: + + # The response is assumed to be encoded in UTF-8... + sline = sline.decode("utf-8") + + # Comments start with a semicolon... + if sline.startswith(";"): + continue + + # Extract network and ignore anything afterwards... + try: + network = ipaddress.ip_network(sline.split()[0], strict=False) + except ValueError: + log.error("Unable to parse line: %s" % sline) + continue + + # Sanitize parsed networks... + if not self._check_parsed_network(network): + log.warning("Skipping bogus network found in Spamhaus DROP URL %s: %s" % \ + (url, network)) + continue + + # Conduct SQL statement... + self.db.execute(""" + INSERT INTO network_overrides( + network, + source, + is_drop + ) VALUES (%s, %s, %s) + ON CONFLICT (network) DO NOTHING""", + "%s" % network, + "Spamhaus DROP lists", + True + ) + + for url in asn_urls: + try: + with downloader.request(url, return_blocks=False) as f: + fcontent = f.body.readlines() + except Exception as e: + log.error("Unable to download Spamhaus DROP URL %s: %s" % (url, e)) + return + + # Iterate through every line, filter comments and add remaining ASNs to + # the override table in case they are valid... + with self.db.transaction(): + for sline in fcontent: + + # The response is assumed to be encoded in UTF-8... + sline = sline.decode("utf-8") + + # Comments start with a semicolon... + if sline.startswith(";"): + continue + + # Throw away anything after the first space... + sline = sline.split()[0] + + # ... strip the "AS" prefix from it ... + sline = sline.strip("AS") + + # ... and convert it into an integer. Voila. + asn = int(sline) + + # Filter invalid ASNs... + if not self._check_parsed_asn(asn): + log.warning("Skipping bogus ASN found in Spamhaus DROP URL %s: %s" % \ + (url, asn)) + continue + + # Conduct SQL statement... + self.db.execute(""" + INSERT INTO autnum_overrides( + number, + source, + is_drop + ) VALUES (%s, %s, %s) + ON CONFLICT (number) DO NOTHING""", + "%s" % asn, + "Spamhaus ASN-DROP list", + True + ) + @staticmethod def _parse_bool(block, key): val = block.get(key)
Hello,
On 23 Oct 2021, at 08:15, Peter Müller peter.mueller@ipfire.org wrote:
The second version of this patch does this in a more Pythonic way.
Hmm, almost.
Signed-off-by: Peter Müller peter.mueller@ipfire.org
src/python/location-importer.in | 19 +++++++++++++++++-- 1 file changed, 17 insertions(+), 2 deletions(-)
diff --git a/src/python/location-importer.in b/src/python/location-importer.in index da058d3..3ad335f 100644 --- a/src/python/location-importer.in +++ b/src/python/location-importer.in @@ -574,6 +574,21 @@ class CLI(object): # be suitable for libloc consumption... return True
- def _check_parsed_asn(self, asn):
"""
Assistive function to filter Autonomous System Numbers not being suitable
for adding to our database. Returns False in such cases, and True otherwise.
"""
validranges = ((1,23455), (23457,64495), (131072, 4199999999))
This should be defined at the top of the file. Otherwise, Python will create and destroy a tuple with these values every time the function is being called. That is a lot of overhead.
I also like writing lists like this as follows:
VALID_ASN_RANGES = ( (1, 23455), (23457, 64495), ... )
That way, changes are easier to read in a diff.
for singlerange in validranges:
You can write this as “for first, last in validranges:”. That way, you have a new variable that expresses what it is all about.
if singlerange[0] <= asn and singlerange[1] >= asn:
return True
log.info("Supplied ASN %s out of publicly routable ASN ranges" % asn)
return False
- def _parse_block(self, block, source_key, validcountries = None): # Get first line to find out what type of block this is line = block[0]
@@ -829,8 +844,8 @@ class CLI(object): log.debug("Skipping ARIN AS names line not containing an integer for ASN") continue
if not ((1 <= asn and asn <= 23455) or (23457 <= asn and asn <= 64495) or (131072 <= asn and asn <= 4199999999)):
log.debug("Skipping ARIN AS names line not containing a valid ASN: %s" % asn)
# Filter invalid ASNs...
if not self._check_parsed_asn(asn): continue # Skip any AS name that appears to be a placeholder for a different RIR or entity...
-- 2.26.2